Export Delays We are currently investigating an issue causing delays in the delivery of on-demand exports.
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 25, 2018 - 10:57 PDT
Identified
We have identified the issue responsible for delays in the delivery of on-demand exports and are working to resolve.
Posted 3 months ago. Sep 25, 2018 - 10:38 PDT
Investigating
We are currently investigating an issue causing delays in the delivery of on-demand exports.
Posted 3 months ago. Sep 25, 2018 - 10:10 PDT