Search Delays
Incident Report for Recurly
Resolved
Our search service is functioning normally.
Posted about 2 years ago. Dec 09, 2015 - 16:11 PST
Monitoring
Search service is stabilizing and being closely monitored, please report any continued issues to Support.
Posted about 2 years ago. Dec 09, 2015 - 13:18 PST
Identified
We're currently experiencing some delays in our search results. If your search does not return, please wait a few minutes and try again. We're monitoring the delay.
Posted about 2 years ago. Dec 09, 2015 - 12:49 PST