Tax Issues
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted Apr 16, 2021 - 06:25 PDT
Monitoring
A fix has been implemented and we are monitoring results
Posted Apr 16, 2021 - 06:20 PDT
Identified
The issue has been identified and fix is being determined.
Posted Apr 16, 2021 - 04:51 PDT
Investigating
We are currently investigating issues with tax service availability
Posted Apr 16, 2021 - 04:15 PDT
This incident affected: 3rd Party Integrations (AvaTax).