Issue with Check Commerce Transactions
Incident Report for Recurly
Resolved
We have identified and resolved the issue with Check Commerce transactions. All transaction processing is back to normal.
Posted Aug 12, 2021 - 15:51 PDT
Investigating
Investigating a possible issue with Check Commerce Transactions
Posted Aug 12, 2021 - 13:32 PDT