Increased Response Times
Incident Report for Recurly
Resolved
All systems are operational now. Please contact support@recurly.com if you have any questions.
Posted 11 months ago. Nov 17, 2016 - 13:06 PST
Investigating
We're currently investigating higher than normal response times. More information to follow here.
Posted 11 months ago. Nov 17, 2016 - 12:28 PST