Invoice Collections Issue
Incident Report for Recurly
Resolved
We have confirmed that impacted invoices have been collected.
Posted Jul 03, 2019 - 15:30 PDT
Investigating
We are investigating reports of an issue impacting the collection of a limited number of invoices. The invoices are queued and will collect when resolved.
Posted Jul 03, 2019 - 12:50 PDT
This incident affected: Admin.