Admin Console Responsiveness
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted 3 months ago. Sep 19, 2018 - 09:02 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. Sep 19, 2018 - 08:33 PDT
Investigating
We are investigating issues with slowness and unavailability of some pages within the admin console.
Posted 3 months ago. Sep 19, 2018 - 08:27 PDT
This incident affected: Admin.