Analytics data may be delayed for some customers.
Incident Report for Recurly
Resolved
We have confirmed resolution and reports will continue to populate with current data.
Posted Mar 25, 2020 - 21:07 PDT
Monitoring
Some customers may experience delayed analytics data reporting for some reports. We have resolved the issue and the data will become current as the day progresses.
Posted Mar 25, 2020 - 08:20 PDT
This incident affected: Data & Analytics (Analytics).