Pending Subscription Changes
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 22, 2019 - 14:36 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. Jul 22, 2019 - 14:18 PDT
Identified
We are experiencing issues modifying subscriptions that already have multiple pending subscription changes. A fix is in the works and we will update when the issue is resolved.
Posted 3 months ago. Jul 22, 2019 - 13:18 PDT