WorldPay issues
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted 7 days ago. Sep 11, 2019 - 12:59 PDT
Monitoring
We noticed an issue which impacted initial transactions for merchants on Worldpay. We have addressed the issue and our team is monitoring.
Posted 7 days ago. Sep 11, 2019 - 11:44 PDT
This incident affected: Admin.