FirstData Processing Issues
Incident Report for Recurly
Resolved
First Data has confirmed that they have resolved the processing issue on their platform and we have confirmed that all transactions are flowing normally. Transactions that have failed as a result of the First Data processing errors will be retried.
Posted 5 months ago. Feb 27, 2019 - 08:59 PST
Update
Status Update: First Data has confirmed an intermittent service disruption on their platform. We continue to monitor this situation closely.
Posted 5 months ago. Feb 27, 2019 - 08:47 PST
Identified
We have identified an issue with FirstData transaction processing and are working to address it. All other gateways are processing correctly.
Posted 5 months ago. Feb 27, 2019 - 08:33 PST
This incident affected: Admin, API, and Third-party Integrations.