Accounts page issues
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted over 3 years ago. Mar 28, 2014 - 12:34 PDT
Update
The /accounts page and search are operational again.
Posted over 3 years ago. Mar 28, 2014 - 12:34 PDT
Investigating
Currently experiencing some issues with our /accounts page. Please navigate to app.recurly.com/go/reports to access your site. The /accounts page should be back up shortly
Posted over 3 years ago. Mar 28, 2014 - 12:10 PDT