Slow Export Download
Incident Report for Recurly
Resolved
Recurly Engineers have resolved an issue where some customers were unable to download exports.
Posted about 1 month ago. Sep 12, 2019 - 09:08 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Sep 12, 2019 - 08:38 PDT
Investigating
We are currently investigating an issue related to the slow download of export files from the Recurly Admin Console.
Posted about 1 month ago. Sep 12, 2019 - 08:15 PDT
This incident affected: Admin.