Emergency Maintenance, 05:00-06:00 PDT 7/27/16
Incident Report for Recurly
Resolved
Maintenance has completed.
Posted 11 months ago. Jul 27, 2016 - 06:13 PDT
Investigating
Recurly will be performing emergency maintenance 7/27/16 between 5am-6am PDT. No impact to our app or API is anticipated. Please contact support@recurly.com if you experience any issues.
Posted 11 months ago. Jul 26, 2016 - 15:53 PDT