Live Chat Issue
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted about 2 months ago. Oct 18, 2018 - 08:48 PDT
Monitoring
Our Live Chat integration has released a fix and we are monitoring the results.
Posted about 2 months ago. Oct 18, 2018 - 08:36 PDT
Identified
We are experiencing issues with our Live Chat integration. Technical Support via Live Chat is temporarily unavailable. Please email support@recurly.com for any questions.
Posted about 2 months ago. Oct 18, 2018 - 08:19 PDT
This incident affected: Admin.