Roku and Check Commerce Issues
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted Aug 09, 2020 - 20:15 PDT
Monitoring
A fix has been implemented and we are monitoring results
Posted Aug 09, 2020 - 20:14 PDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 09, 2020 - 20:06 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 09, 2020 - 19:56 PDT
Investigating
We are investigating issues with payment processing using Roku and Check Commerce.
Posted Aug 09, 2020 - 19:18 PDT