Export delays
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted 21 days ago. Oct 03, 2018 - 06:15 PDT
Investigating
We are investigating reports of delayed exports.
Posted 21 days ago. Oct 03, 2018 - 04:40 PDT