Our platform is continuously monitored for outages, slowdowns, or other issues. Should there be any interruptions in service, we'll provide status updates here.
Get email notifications whenever Recurly creates, updates or resolves an incident.
Get text message notifications whenever Recurly creates or resolves an incident.
Get webhook notifications whenever Recurly creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 08, 2022 - 08:00 PDT
Scheduled
Recurly will be performing updates to its DNS systems which could increase response times briefly. Any Merchants already using our Direct Connect solution will not be impacted.
Posted Sep 02, 2022 - 11:06 PDT
This scheduled maintenance affected: Admin Console and API.