Avalara Downtime
Incident Report for Recurly
Resolved
All Avalara services have been fully restored. See https://status.avalara.com/ for details.
Posted 7 months ago. Apr 09, 2018 - 14:12 PDT
Monitoring
Avalara is reporting downtime, impacting some tax processing inside of Recurly. See https://status.avalara.com/ for updates.
Posted 7 months ago. Apr 09, 2018 - 10:19 PDT