application errors
Incident Report for Recurly
Resolved
Recurly Engineers have successfully resolved the issue, please contact support if you need further assistance at https://support.recurly.com
Posted May 21, 2020 - 14:26 PDT
Monitoring
A fix has been implemented and we are currently monitoring the application.
Posted May 21, 2020 - 14:15 PDT
Identified
we are investigating application errors at this time.
Posted May 21, 2020 - 14:10 PDT
This incident affected: Admin Console.