Slow Export Downloads
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted 21 days ago. Aug 28, 2019 - 08:16 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 21 days ago. Aug 28, 2019 - 07:34 PDT
Investigating
We are currently investigating an issue related to the slow download of file exports. No other Recurly services are impacted.
Posted 21 days ago. Aug 28, 2019 - 06:20 PDT
This incident affected: Admin.