PayPal Initial Signups
Incident Report for Recurly
Resolved
Issues with PayPal signups have been resolved by PayPal and new signups are working correctly again.
Posted Feb 17, 2023 - 07:35 PST
Investigating
We are investigating issues creating new signups using PayPal
Posted Feb 17, 2023 - 06:06 PST
This incident affected: Admin Console (Admin Console).