We are investigating reports of email delays
Incident Report for Recurly
Resolved
Emails that were delayed have now been sent.
Posted Aug 09, 2019 - 18:16 PDT
Monitoring
We have implemented a fix for delayed emails. Our team is monitoring.
Posted Aug 09, 2019 - 14:15 PDT
Investigating
We are investigating reports of email delays.
Posted Aug 09, 2019 - 13:40 PDT