Email Deliverability
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted Mar 24, 2021 - 09:55 PDT
Monitoring
Monitoring results
Posted Mar 24, 2021 - 09:26 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 24, 2021 - 08:54 PDT
Investigating
We are investigating reports of email deliverability issues.
Posted Mar 24, 2021 - 08:03 PDT