Analytics Delay
Incident Report for Recurly
Resolved
We have resolved the delays in the Billings Analytics Dashboard for Recurly sites with non-USD currency codes
Posted May 31, 2021 - 10:12 PDT
Identified
Our engineers have determined the source of the issue and are currently implementing a fix.
Posted May 31, 2021 - 09:29 PDT
Update
We have confirmed an issue with delays in the Billings Analytics Dashboard for Recurly sites with non-USD currency codes. Our engineers are currently working on the issue.
Posted May 31, 2021 - 09:17 PDT
Investigating
We are investigating delays in Analytics in Recurly UI.
Posted May 31, 2021 - 08:58 PDT
This incident affected: Data & Analytics (Analytics) and API.