Recurring Invoice Collections
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted Feb 28, 2022 - 18:16 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 28, 2022 - 16:56 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 28, 2022 - 15:20 PST
Investigating
Our engineers are working on a fix for the delay on recurring invoice collections.
Posted Feb 28, 2022 - 14:06 PST
This incident affected: Admin Console and API.