we are investing issues with site availability
Incident Report for Recurly
Resolved
We have confirmed the issues has been resolved, if you need additional assistance please contact support at https://support.recurly.com
Posted Jul 17, 2020 - 16:05 PDT
Monitoring
We are monitoring an incident with Cloudflare which has impacted traffic routing across a large portion of the internet. Please see https://www.cloudflarestatus.com/incidents/b888fyhbygb8 for additional details.
Posted Jul 17, 2020 - 14:40 PDT
Investigating
we are investing issues with site availability
Posted Jul 17, 2020 - 14:20 PDT
This incident affected: Admin Console.