Export Delays
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted 6 days ago. Aug 12, 2019 - 08:39 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 6 days ago. Aug 12, 2019 - 07:15 PDT
Identified
Exports from the Recurly admin console are taking longer than expected to download. We have identified the issue and are working on a fix.
Posted 6 days ago. Aug 12, 2019 - 04:57 PDT