Email Deliverability Delays
Incident Report for Recurly
Resolved
Email delivery has been restored for all recipient domains.
Posted 2 months ago. Dec 14, 2016 - 06:37 PST
Monitoring
Email delivery delays have been resolved for most recipient domains. We continue to monitor sporadic issues with some locations. Updates will be posted here as we have them.
Posted 3 months ago. Dec 09, 2016 - 16:47 PST
Identified
We're aware of an issue causing email deliverability delays and are actively working on the issue. All emails are queued and will be delivered.
Posted 3 months ago. Dec 09, 2016 - 07:56 PST