Email Deliverability Delay
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted 2 months ago. Aug 07, 2019 - 09:24 PDT
Monitoring
Email queues are now catching up and we are monitoring for ongoing deliverability success.
Posted 2 months ago. Aug 07, 2019 - 08:34 PDT
Identified
The issue has been identified.
Posted 2 months ago. Aug 07, 2019 - 07:17 PDT
Investigating
We are investigating a delay in email deliverability.
Posted 2 months ago. Aug 07, 2019 - 07:06 PDT