Issues with PayPal Business Transactions
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted over 2 years ago. Aug 01, 2014 - 12:36 PST
Update
Posted over 2 years ago. Aug 01, 2014 - 12:36 PST
Investigating
We are noticing some intermittent timeouts when connecting to paypal, this has been raised with both our ISP and paypal and we will keep you updated.
Posted over 2 years ago. Aug 01, 2014 - 11:54 PST