Degraded Performance
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted Feb 11, 2021 - 02:45 PST
Monitoring
The Recurly platform is no longer experiencing degraded service. We are continuing to monitor the situation.
Posted Feb 11, 2021 - 00:44 PST
Investigating
We are investigating issues with degraded performance and availability of the Admin UI.
Posted Feb 11, 2021 - 00:31 PST
This incident affected: Admin Console and API.