PayPal Reference Transactions Connection Issues
Incident Report for Recurly
Resolved
Connection issues with PayPal have been resolved. Any recurring transactions will be retried.
Posted over 2 years ago. Oct 15, 2014 - 09:43 PDT
Identified
We are currently experiencing issues connecting to PayPal for PayPal reference transactions. Our operations team is engaged and we will update you shortly.
Posted over 2 years ago. Oct 15, 2014 - 09:14 PDT