degraded application performance
Incident Report for Recurly
Resolved
Recurly Engineers have resolved the issue.
Posted Feb 06, 2020 - 16:10 PST
Monitoring
Application performance has been restored.
Posted Feb 06, 2020 - 14:20 PST
Investigating
Some customers may experience degraded performance, our engineers are working to resolved the issue.
Posted Feb 06, 2020 - 14:05 PST
This incident affected: Admin Console.