Planned Maintenance
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted almost 3 years ago. Apr 24, 2014 - 22:04 PST
Update
Search maintenance complete.
Posted almost 3 years ago. May 24, 2014 - 22:04 PST
Investigating
Our search upgrade work is beginning now. Search may be slow during this time. Some accounts and transactions may not show up in the search page, but will be available in search shortly following the upgrade.
Posted almost 3 years ago. Apr 24, 2014 - 21:50 PST