Delay in email delivery
Incident Report for Recurly
Resolved
All queued emails were resent.
Posted over 2 years ago. Jan 16, 2015 - 11:37 PST
Identified
We're currently experiencing a delay in delivering selective emails. These emails are queued and will be sent.
Posted over 2 years ago. Jan 16, 2015 - 08:02 PST