Email Delays
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted Jul 02, 2020 - 08:29 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 02, 2020 - 06:26 PDT
Investigating
We’re investigating delays in email deliverability.
Posted Jul 02, 2020 - 06:22 PDT