Search
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted over 3 years ago. Mar 24, 2014 - 15:27 PDT
Update
We've rolled out a new version of our search functionality backed by new hardware. Please contact support@recurly.com with any questions or issues.
Posted over 3 years ago. Mar 24, 2014 - 15:37 PDT
Investigating
Working on search improvements, temporary slowness or timeouts will occur as work is underway
Posted almost 4 years ago. Feb 26, 2014 - 10:11 PST