Transactions Processing Issues
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 04, 2019 - 16:08 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 3 months ago. Apr 04, 2019 - 16:04 PDT
Investigating
We are exploring an issue with payment processing. Recurring transactions are paused and new signups may need to be retried once resolved.
Posted 3 months ago. Apr 04, 2019 - 15:55 PDT
This incident affected: Third-party Integrations.