Delayed or Incomplete Exports
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted about 1 month ago. May 17, 2017 - 08:43 PDT
Investigating
We are investigating an issue with possible delayed or incomplete exports for some customers. We will provide further updates as available.
Posted about 1 month ago. May 17, 2017 - 03:06 PDT