Braintree Gateway Connection Issues
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted 12 months ago. Aug 30, 2016 - 06:18 PDT
Investigating
We are investigating connection issues with the Braintree payment gateway.
Posted 12 months ago. Aug 30, 2016 - 03:38 PDT