Currently experiencing increased database load.
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted almost 3 years ago. Jul 23, 2014 - 17:25 PDT
Update
We're continuing to investigate issues in our database cluster, but all services should be functioning at this time. Please contact support@recurly.com with any questions.
Posted almost 3 years ago. Jul 23, 2014 - 12:09 PDT
Investigating
Our ops team is engaged and we will update as more information is available
Posted almost 3 years ago. Jul 23, 2014 - 12:09 PDT