Recurly admin console degraded performance issue.
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted Feb 03, 2020 - 16:58 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 03, 2020 - 16:46 PST
Identified
We’ve identified an issue within the Admin Console that will prevent users from adding a one-time charge or credit.
Posted Feb 03, 2020 - 15:48 PST
This incident affected: Admin Console.