Avalara disruption
Incident Report for Recurly
Resolved
This incident has been resolved.
Posted about 2 months ago. Jan 27, 2017 - 14:58 PDT
Monitoring
Recurly is monitoring a service disruption at one of our partners. Merchants with integrations to Avalara may experience slower response times.
Posted about 2 months ago. Jan 27, 2017 - 13:51 PDT